Tic-tac-toe Collection
Blog

Dropping support for Android Jelly Bean

Sadly, this has been bound to happen for a while now.

Some time in the near future, the minimum required Android version for Tic-tac-toe Collection will be changed to KitKat - 4.4. That means devices running 4.3 or lower will no longer receive updates. Existing installations will no longer be affected.

The broad reason for this is simply that Android 4.3 is old (4.4 was released in September 2013). Finding devices to test on is not straight forward and running an emulator below 4.4 is a pain. The more specific reason is that Xamarin Forms (a library Tic-tac-toe Collection depends on) is changing its minimum Android version to 4.4.

For reference, according to my information there have been a total 0f 18 devices install Tic-tac-toe on Android 4.3 or lower.

Announcements